The Third Party has resolved the technical issue with Accel network. The service is now operating as expected.
Posted Mar 03, 2026 - 07:24 UTC
Identified
We are continuing to experience a technical issue with Accel network that may be causing transaction processing errors. Third party technical resources are continuing to work to resolve the issue. Further updates will be provided as additional information becomes available.
Posted Mar 03, 2026 - 05:59 UTC
Investigating
We are currently aware of a technical issue with Accel network that may be causing transaction processing errors. Technical resources are monitoring the issue and will provide updates as received.