INC0325639 - We are investigating issues with Integrated Payments, Paymetric, Express, Mercury, Core iQ, SAS Fraud, Biller Solutions, PayDirect and Worldpay Core Processing platforms.

Incident Report for Worldpay Platform Status Page

Resolved

Worldpay technical teams resolved an internal network issue to restore service. Worldpay will continue to monitor the environment for stability.
Posted Dec 02, 2025 - 23:12 UTC

Update

As of 14:00 ET, outstanding issues with Integrated Payments, PayDirect, CMP Network Payments Tokenization, Paymetric, and Worldpay Core Processing have been resolved.

Technical teams are continuing to mitigate any remaining impact and are working to restore additional network connectivity. Further updates will be provided as additional information becomes available.
Posted Dec 02, 2025 - 22:01 UTC

Update

As of 14:00 ET, outstanding issues with Integrated Payments, PayDirect, CMP Network Payments Tokenization and Worldpay Core Processing have been resolved.

Technical teams are continuing to mitigate any remaining impact and are working to restore additional network connectivity. Further updates will be provided as additional information becomes available.
Posted Dec 02, 2025 - 20:00 UTC

Update

As of 14:00 ET, outstanding issues with Integrated Payments, PayDirect, CMP Network Payments Tokenization and Worldpay Core Processing have been resolved.

Technical teams are continuing to mitigate any remaining impact and are working to restore additional network connectivity.
Posted Dec 02, 2025 - 19:10 UTC

Update

Worldpay technical teams are continuing to work to resolve an internal network issue to restore services.
Posted Dec 02, 2025 - 18:02 UTC

Update

Worldpay technical teams have identified an internal network issue and are continuing to work to restore connectivity.
Posted Dec 02, 2025 - 17:10 UTC

Update

Worldpay technical teams have identified an internal network issue and are continuing to work to mitigate the impact.
Posted Dec 02, 2025 - 15:49 UTC

Update

Worldpay technical teams remain engaged and are continuing to work to mitigate the impact.
Posted Dec 02, 2025 - 14:38 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 02, 2025 - 14:01 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 02, 2025 - 14:01 UTC

Identified

Worldpay technical resources are working to identify and resolve the issue.
Posted Dec 02, 2025 - 13:54 UTC

Investigating

We are currently experiencing a technical issue with Authorization & Payments. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Dec 02, 2025 - 13:43 UTC
This incident affected: Authorization & Payments and Acquiring Services.