INC0441654 - Payouts - Worldpay Alternative Payments (WPAP) platform

Incident Report for Worldpay Platform Status Page

Resolved

Worldpay technical resources resolved an internal issue to restore the service. Support teams confirmed that as of 14:39 ET, all payouts have been processed.
Posted Mar 15, 2026 - 20:18 UTC

Update

Worldpay technical resources resolved an internal issue to restore the service. Support teams confirmed that as of 14:39 ET, all payouts have been processed.
Posted Mar 15, 2026 - 20:16 UTC

Identified

We are currently experiencing an incident affecting Payout transactions on the Worldpay Alternative Payments (WPAP) platform when processing via Modulr. Due to banking hours, funding will not be available until Monday, 16-Mar-2026.
Posted Mar 15, 2026 - 08:57 UTC

Investigating

There is an incident affecting Payout transactions on the Worldpay Alternative Payments (WPAP) platform when processing through Modulr. Due to banking hours, funding will not be available until Monday 16-Mar-2026.
Posted Mar 14, 2026 - 21:09 UTC
This incident affected: Funding & Payouts.