We have resolved the technical issue with Authorization & Payments impacting the Worldpay Total and Worldpay 360 platforms. Transactions may have received an error during processing or may have been declined. The system is now operating as expected. We apologize for any inconvenience this may have caused you or your customers.
Posted Mar 24, 2026 - 17:38 UTC
Update
We are continuing to experience a technical issue with Authorization & Payments on the Worldpay Total and Worldpay 360 platforms. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Mar 24, 2026 - 17:32 UTC
Identified
We are currently experiencing a technical issue with Authorization & Payments impacting the Worldpay Total and Worldpay 360 platforms. Technical resources are continuing to work to resolve the issue as a matter of priority.
Posted Mar 24, 2026 - 16:11 UTC
Investigating
We are currently experiencing a technical issue with Authorization & Payments impacting the Worldpay Total platform. Technical resources are working to identify and resolve the issue as a matter of priority.