INC0324711 - We are investigating a potential issue impacting the PayDirect application

Incident Report for Worldpay Platform Status Page

Resolved

Worldpay technical teams resolved an internal issue to restore service to the PayDirect application. Worldpay will continue to monitor the environment for stability.
Posted Dec 01, 2025 - 17:22 UTC

Investigating

The PayDirect application is experiencing a service issue. Multipay, Enrollments, IVR and Datapointe may be unavailable. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Dec 01, 2025 - 16:24 UTC
This incident affected: Portals & Reporting.