The technical issue with some Point of Sale terminals has been resolved. The system is now operating as expected. We apologise for any inconvenience this may have caused you or your customers.
Posted Feb 10, 2026 - 12:25 UTC
Identified
We are continuing to experience a technical issue with connection of Point-of-Sale terminals. Technical resources are working to identify and resolve the issue as a matter of priority. Upon resolution update will be shared.
Posted Feb 10, 2026 - 09:53 UTC
Investigating
We are aware that some point of sale terminals are experiencing connection issues. You can find card machine troubleshooting guides by visiting help.worldpay.com, and searching for "card machines"