INC0538187 - A power grid issue caused a temporary power disruption which impacted transaction authorisation and tokenization requests on multiple platforms.

Incident Report for Worldpay Platform Status Page

Resolved

A third-party power disruption caused intermittent transaction authorisation and tokenization issues on some Worldpay platforms. Our technical teams have completed restoration efforts and are now observing stability on the affected platforms.
Posted Jun 23, 2026 - 22:35 UTC

Update

A third-party power disruption is causing intermittent transaction authorisation issues and tokenization requests errors on some Worldpay platforms. Our technical teams have restored service to some platforms and continue to troubleshoot to restore full service as soon as possible.
Posted Jun 23, 2026 - 21:44 UTC

Update

A third-party power disruption is causing intermittent transaction authorisation issues on some Worldpay platforms. Some transaction authorizations and tokenization requests may result in an error or be declined. Our technical teams are engaged and working to restore service as soon as possible.
Posted Jun 23, 2026 - 20:59 UTC

Identified

A third-party power outage is affecting transaction authorisations on multiple Worldpay platforms. Some transactions may be declined or result in an error. Worldpay technical resources are continuing to work to recover all affected platforms and restore service.
Posted Jun 23, 2026 - 20:27 UTC

Update

A third-party power outage is affecting transaction authorisations on multiple Worldpay platforms. Some transactions may be declined or result in an error. Worldpay technical resources are working to recover all affected platforms.
Posted Jun 23, 2026 - 20:08 UTC

Investigating

We are currently experiencing a technical issue with Authorization & Payments. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Jun 23, 2026 - 19:48 UTC
This incident affected: Authorization & Payments.