INC0513622 - We are investigating potential issues with iQ Merchant Daily Reports

Incident Report for Worldpay Platform Status Page

Resolved

Worldpay technical resources resolved an internal issue to restore service. Worldpay will continue to monitor the environment for stability.
Posted May 28, 2026 - 17:21 UTC

Update

Some Merchant Daily iQ reports may be delayed. Worldpay’s technical teams are continuing to resolve the issue and generate the delayed reports.
Posted May 28, 2026 - 15:42 UTC

Investigating

We are currently experiencing a technical issue with the availability of some iQ Merchant Daily reports. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted May 28, 2026 - 13:36 UTC
This incident affected: Portals & Reporting.