INC0233261 - We are investigating potential issues with Acquiring Services

Incident Report for Worldpay Platform Status Page

Resolved

There was a certificate issue with some UK based Point of Sale (POS) terminals. An automated certificate update was pushed to affected terminals once connected to the network. Worldpay technical teams will continue to monitor the environment for stability.
Posted Sep 10, 2025 - 14:25 UTC

Update

We are continuing to experience a technical issue with some UK based Point of Sale (POS) terminals. Technical resources are working to resolve the issue as a matter of priority.
Posted Sep 10, 2025 - 12:07 UTC

Update

We are continuing to experience a technical issue with some UK based Point of Sale (POS) terminals. Technical resources are continuing to resolve the issue as a matter of priority.
Posted Sep 09, 2025 - 11:24 UTC

Identified

We are continuing to experience a technical issue with some UK based Point of Sale (POS) terminals. Technical resources are working to resolve the issue as a matter of priority.
Posted Sep 08, 2025 - 09:18 UTC

Investigating

We are currently experiencing a technical issue with Acquiring Services. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Sep 05, 2025 - 23:59 UTC
This incident affected: Acquiring Services.