INC0198221 - We are investigating potential issues with Portals & Reporting

Incident Report for Worldpay Platform Status Page

Resolved

Worldpay technical resources reverted an internal change to restore service. Worldpay will continue to monitor the environment for stability.
Posted Aug 01, 2025 - 18:03 UTC

Investigating

We are currently experiencing a technical issue with authentication into XiPay.worldpay.com. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Aug 01, 2025 - 17:26 UTC
This incident affected: Portals & Reporting.