INC0329570 There is a third-party incident intermittently affecting Maestro network transaction authorizations when processing on the Worldpay Core Processing (RAFT) platform.

Incident Report for Worldpay Platform Status Page

Resolved

The issue resolved without any technical intervention by Worldpay. Worldpay will continue to monitor the processing environment for stability.
Posted Dec 04, 2025 - 03:48 UTC

Investigating

There is a third-party incident intermittently affecting Maestro network transaction authorizations when processing on the Worldpay Core Processing (RAFT) platform.
Posted Dec 04, 2025 - 02:30 UTC
This incident affected: Authorization & Payments.