INC0394898 - We are investigating potential issues with DX8000 and Move Terminals

Incident Report for Worldpay Platform Status Page

Resolved

A third-party provider acknowledged a drop in global sim sessions due to an outage. The provider has confirmed that the issue is now resolved.
Posted Feb 02, 2026 - 15:55 UTC

Identified

We are aware of an issue impacting DX8000 and Move terminals. Please switch your terminal to Wi-Fi to correct the issue. For help on how to do so, visit help.worldpay.com and search your terminal model and wifi troubleshooting.
Posted Feb 02, 2026 - 14:30 UTC

Investigating

We are currently experiencing a technical issue with Acquiring Services. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Feb 02, 2026 - 14:22 UTC
This incident affected: Acquiring Services.