INC0615168 - Mastercard Debit - Transaction Authorizations

Incident Report for Worldpay Platform Status Page

Resolved

There was an increase in failures for transactions processing on the Mastercard Debit network. Some Debit transactions may have been declined between 09:53 ET – 10:02 ET. The issue was resolved without intervention from Worldpay technical resources. All Worldpay systems operated normally throughout the duration of the incident.
Posted Aug 11, 2026 - 14:58 UTC

Investigating

There is an increase in failures for transactions processing on the Mastercard Debit network. Some Debit transactions may be declined. Mastercard technical resources are working to identify and resolve the issue. All Worldpay systems are operating normally and the environment will be monitored for recovery.
Posted Aug 11, 2026 - 14:11 UTC
This incident affected: Authorization & Payments.