We have resolved the technical issue with Authorization & Payments on the Worldpay Total platform. The system is now operating as expected. We apologize for any inconvenience this may have caused you or your customers.
Posted Aug 01, 2025 - 17:41 UTC
Update
Worldpay support is investigating an incident impacting transaction authorizations on the Worldpay Total platform. More information will be provided as it becomes available.
Posted Aug 01, 2025 - 17:16 UTC
Investigating
We are currently experiencing a technical issue with Authorization & Payments. Technical resources are working to identify and resolve the issue as a matter of priority.