INC0331704 - There is an external issue with a third-party provider that is affecting telephony services to the Worldpay Contact Center.

Incident Report for Worldpay Platform Status Page

Resolved

The external third-party vendor rolled back a recent change to restore service. The service is now operating as expected. We apologise for any inconvenience this may have caused you or your customers.
Posted Dec 06, 2025 - 04:48 UTC

Monitoring

The external third-party vendor has successfully rolled back a recent change. Worldpay teams are currently validating that inbound calls have been fully restored and will continue to monitor the environment to ensure complete recovery.
Posted Dec 06, 2025 - 02:30 UTC

Update

Worldpay’s mitigation measures have successfully restored the majority of inbound calls; however, a small number of calls may still experience disconnections. The vendor continues to work to restore service. Worldpay will continue to monitor the environment for recovery.
Posted Dec 06, 2025 - 00:14 UTC

Update

The Contact Center toll-free numbers have been re-routed to mitigate impact while the vendor works to restore service. Worldpay will continue to monitor the environment for recovery.
Posted Dec 05, 2025 - 22:54 UTC

Update

Third-party technical resources are continuing to work to restore service. Worldpay will continue to monitor the telephony environment for recovery.
Posted Dec 05, 2025 - 21:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 05, 2025 - 20:53 UTC

Identified

There is an external issue with a third-party provider that is affecting telephony services to the Worldpay Contact Center. Some inbound calls may be unable to connect to agents. Third-party telephony resources are currently working to restore service.
Posted Dec 05, 2025 - 19:43 UTC

Update

There is an issue intermittently affecting telephony services to the Worldpay Contact Center. Some inbound calls may be unable to connect to agents. Worldpay technical resources are working to identify and resolve the issue.
Posted Dec 05, 2025 - 18:12 UTC

Investigating

We are currently experiencing a technical issue with Telephony Services. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Dec 05, 2025 - 17:42 UTC
This incident affected: Portals & Reporting.