We have resolved the technical issue with Funding & Payouts on the Worldpay Total platform. A subset of Worldpay Total customers who were scheduled to receive funding 24-Jun-2026, will receive funds 25-Jun-2026 or one-day later than expected according to the customer funding cycle. All processing is now complete. Delayed funding will be paid to impacted customers once processed by card schemes 25-Jun-2026.
Posted Jun 24, 2026 - 07:13 UTC
Identified
We are continuing to experience a technical issue which has caused a one-day funding delay for a subset of merchants on the Worldpay Total (WPT) platform. Technical resources are working to process the affected files.
Posted Jun 24, 2026 - 05:14 UTC
Update
We are continuing to experience a technical issue which has caused a one-day funding delay for a subset of merchants on the Worldpay Total (WPT) platform. Technical resources are working to process the affected files.
Posted Jun 24, 2026 - 05:12 UTC
Investigating
We are currently experiencing a technical issue with Funding & Payouts. Technical resources are working to identify and resolve the issue as a matter of priority.