There was a third-party issue which affected Electronic Benefit Transfer (EBT) and Women, Infants, and Children (WIC) transactions processing in multiple states. FIS Global technical resources identified and resolved an internal issue to restore service. All Worldpay systems were operating normally throughout the duration of the incident.
Posted Aug 06, 2026 - 02:05 UTC
Update
There was a third-party issue which affected Electronic Benefit Transfer (EBT) and Women, Infants, and Children (WIC) transactions processing in multiple states. FIS Global technical resources identified and resolved an internal issue to restore service. All Worldpay systems were operating normally throughout the duration of the incident.
Posted Aug 05, 2026 - 21:32 UTC
Identified
We are currently observing a third-party technical issue affecting Authorization & Payments for Electronic Benefit Transfer and Women, Infants, and Children (WIC) transactions for multiple states. FIS Global technical resources identified an internal issue and have restored service as of 16:49 ET. Worldpay is continuing to observe increased response times and is monitoring the environment for full recovery. All Worldpay systems are operating normally.
Posted Aug 05, 2026 - 20:58 UTC
Investigating
We are currently observing a third-party technical issue affecting Authorization & Payments for Women, Infants, and Children (WIC) transactions in the state of New York. Worldpay technical resources are engaging FIS Global to assist with troubleshooting the failures. All Worldpay systems are operating normally.