We have resolved the technical issue with Funding & Payouts. The service is now operating as expected. We apologise for any inconvenience this may have caused you or your customers.
Posted Jul 29, 2025 - 09:17 UTC
Update
We are continuing to experience a technical issue with Funding & Payouts for Acquiring Platform customers. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Jul 28, 2025 - 14:20 UTC
Identified
We are continuing to experience a technical issue with Funding & Payouts for some Acquiring Platform customers. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Jul 28, 2025 - 14:01 UTC
Investigating
We are currently experiencing a technical issue with Funding & Payouts. Technical resources are working to identify and resolve the issue as a matter of priority.