INC0554680 - We are investigating issues with Authorization & Payments

Incident Report for Worldpay Platform Status Page

Resolved

The incident was resolved without technical intervention from Worldpay resources. All Worldpay systems were operating normally throughout the duration of the incident. Worldpay will continue to monitor the environment for stability.
Posted Jul 01, 2026 - 00:18 UTC

Investigating

We are currently experiencing a technical issue with Authorization & Payments for NYCE network. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted Jun 30, 2026 - 23:22 UTC
This incident affected: Authorization & Payments.