INC0501663 - We are aware of an issue with Authorization & Payments on the Visa network.

Incident Report for Worldpay Platform Status Page

Resolved

Visa technical teams reported that as of 20:38 ET, transaction processing had normalized. This issue was resolved without technical intervention from Worldpay teams. Worldpay will continue to monitor the environment for stability.
Posted May 16, 2026 - 01:07 UTC

Update

We are continuing to experience a technical issue with Authorization & Payments. Worldpay and Visa technical resources are currently troubleshooting the issue.
Posted May 15, 2026 - 23:07 UTC

Investigating

We are currently experiencing an issue with Authorization & Payments on the Visa network. Technical resources are working to identify and resolve the issue as a matter of priority.
Posted May 15, 2026 - 22:28 UTC
This incident affected: Authorization & Payments.