INC0418953- A third-party experienced an incident which intermittently affected Visa, Maestro and Pulse network transactions on the Worldpay Core Processing platform.

Incident Report for Worldpay Platform Status Page

Resolved

Third-party technical resources have resolved the issue and restored service. All Worldpay systems were operating normally. Worldpay will continue to monitor the environment for stability.
Posted Feb 24, 2026 - 21:33 UTC

Update

Third-party technical resources are continuing to work to resolve the issue and restore service. All Worldpay systems are operating normally. Worldpay will continue to monitor the environment for recovery.
Posted Feb 24, 2026 - 19:53 UTC

Investigating

We are currently investigating this issue.
Posted Feb 24, 2026 - 18:58 UTC