INC0198364 - We are aware of potential issues with a Third Party provider.

Incident Report for Worldpay Platform Status Page

Resolved

The Third Party has resolved the technical issue with eps. The service is now operating as expected.
Posted Aug 01, 2025 - 22:34 UTC

Identified

We are continuing to experience a technical issue with eps that may be causing transaction timeouts or declines. Our technical resources continue to work with the Third Party to resolve the issue as a matter of priority.

NEXT UPDATE: 2025-08-01 22:30:00 UTC | 2025-08-01 18:30:00 EDT
Posted Aug 01, 2025 - 20:33 UTC

Update

We are continuing to investigate this issue.
Posted Aug 01, 2025 - 19:32 UTC

Investigating

We are currently aware of a technical issue with eps that may be causing transaction timeouts or declines. eps technical resources are monitoring the issue and will provide updates as received.
Posted Aug 01, 2025 - 19:30 UTC
This incident affected: Authorization & Payments.